Getting Started

Game Basic 3D Engine Build 4096
Overview
Send comments on this topic.
The purpose of this help file is to provide the technical documentation for the API reference of the Game Basic 3D Engine.

How do I get started?

The best way to get started is to refer to the training tutorials located on the Game Basic website.

Each tutorial is designed to teach one particular topic. By completing each lesson you will accumulate the knowledge necessary to take full advantage of the tremendous features Game Basic provides.
Copyright © Monarke Studios. All Rights Reserved.


Getting Started

Game Basic 3D Engine Build 4096
License
Send comments on this topic.
The following License information is a synopsis of the full EULA and does not constitute the legal agreement contained within the EULA. The EULA is the definitive legal agreement on the use of Game Basic. This synopsis is provided simply as a quick reference for the basics of who can use Game Basic and under what conditions. For the full legal details please refer to the End User License Agreement.

Personal

The license is intended to make the source code of the engine available to everyone who wants the opportunity to use and contribute to the project. Game Basic 3D is a commercial product. It is not in the public domain or "freeware" or "shareware". By making the source code available we are not giving it away or abandoning our right of ownership.

Under the Personal/Non-Commercial License you may build whatever software products you wish. You may freely distribute your developed work provided:

  • The Game Basic source code is not included in the distributed product.
  • You may not charge any form of fee for your work.
  • You must continue to display the introduction.

Commercial

The primary restriction of the commercial license is that the Game Basic source code may not be included in any product release; whether for demonstration or sale, but provides you with the ability to create and sell your own developed works without any other restrictions from the Game Basic end user license.


Camera Object
See Also Members Send comments on this topic.
The Camera object covers the group of components which together make up the entire perspective.

See Also

Camera Members


Camera Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Move
Public Method Rotate
Public Method Set2DFieldOfView
Public Method Set3DFieldOfView
Public Method SetPosition
Public Method SetRotation

Public Properties

Public Property Direction
Public Property Position
Public Property Rotation

See Also

Camera Overview


Move Method
See Also Send comments on this topic.
X
Y
Z

Syntax

Visual Basic
Public Sub Move( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Camera Object


Rotate Method
X
Y
Z

Syntax

Visual Basic
Public Sub Rotate( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Camera Object


Set2DFieldOfView Method
Value

Syntax

Visual Basic
Public Sub Set2DFieldOfView( _
   ByVal Value As Single _
)

Parameters

Value

See Also

Camera Object


Set3DFieldOfView Method
Value

Syntax

Visual Basic
Public Sub Set3DFieldOfView( _
   ByVal Value As Single _
)

Parameters

Value

See Also

Camera Object


SetPosition Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetPosition( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Camera Object


SetRotation Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetRotation( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Camera Object


Direction Property

Property type

Read-only property

Syntax

Visual Basic
Public Property Direction() As Vertex3

See Also

Camera Object


Position Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Position() As Vertex3

See Also

Camera Object


Rotation Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Rotation() As Vertex3

See Also

Camera Object


Console Object
See Also Members Send comments on this topic.
The Console object is the interface the user uses to manipulate parameters which can be passed into and out of the environment.

See Also

Console Members


Console Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Clear
Public Method Load
Public Method Update
Public Method UnLoad

Public Properties

Public Property Background
Public Property Command
Public Property Progress
Public Property Visible

See Also

Console Overview


Clear Method

Syntax

Visual Basic
Public Sub Clear()

See Also

Console Object


Load Method
Name

Syntax

Visual Basic
Public Sub Load( _
   ByVal Name As String _
)

Parameters

Name

See Also

Console Object


Update Method
Text

Syntax

Visual Basic
Public Function Update( _
   Optional ByVal Text As String _
) As Boolean

Parameters

Text

See Also

Console Object


UnLoad Method
Name

Syntax

Visual Basic
Public Sub UnLoad( _
   ByVal Name As String _
)

Parameters

Name

See Also

Console Object


Background Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Background() As Shader_Type

See Also

Console Object


Command Property
Name

Property type

Read-only property

Syntax

Visual Basic
Public Property Command( _
   ByVal Name As String _
) As Variant

Parameters

Name

See Also

Console Object


Progress Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Progress() As Shader_Type

See Also

Console Object


Visible Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Visible() As Boolean

See Also

Console Object


Cursor Object
See Also Members Send comments on this topic.
The Cursor object is an input control and the main focal point within the environment by which objects can interact with.

See Also

Cursor Members


Cursor Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method BeginSelection
Public Method CheckSelection
Public Method EndSelection
Public Method Render
Public Method Update

Public Properties

Public Property Axes
Public Property Button
Public Property Direction
Public Property Position
Public Property Relative
Public Property Rotation
Public Property Shader

See Also

Cursor Overview


BeginSelection Method
Name

Syntax

Visual Basic
Public Sub BeginSelection( _
   ByVal Name As String _
)

Parameters

Name

See Also

Cursor Object


CheckSelection Method
Name

Syntax

Visual Basic
Public Function CheckSelection( _
   Optional ByVal Name As String _
) As Boolean

Parameters

Name

See Also

Cursor Object


EndSelection Method

Syntax

Visual Basic
Public Sub EndSelection()

See Also

Cursor Object


Render Method
X
Y
Size

Syntax

Visual Basic
Public Sub Render( _
   Optional ByVal X As Single, _
   Optional ByVal Y As Single, _
   Optional ByVal Size As Single = 1 _
)

Parameters

X
Y
Size

See Also

Cursor Object


Update Method

Syntax

Visual Basic
Public Sub Update()

See Also

Cursor Object


Axes Property

Property type

Read-only property

Syntax

Visual Basic
Public Property Axes() As Vertex2Long

See Also

Cursor Object


Button Property
Control

Property type

Read-only property

Syntax

Visual Basic
Public Property Button( _
   ByVal Control As CURSOR_CONTROLS _
) As Boolean

Parameters

Control
Value
MOUSE_LEFT
MOUSE_MIDDLE
MOUSE_RIGHT

See Also

Cursor Object


Direction Property

Property type

Read-only property

Syntax

Visual Basic
Public Property Direction() As Vertex3

See Also

Cursor Object


Position Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Position() As Vertex2Long

See Also

Cursor Object


Relative Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Relative() As Boolean

See Also

Cursor Object


Rotation Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Rotation() As Vertex2Long

See Also

Cursor Object


Shader Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Shader() As Shader_Type

See Also

Cursor Object


Engine Object
See Also Members Send comments on this topic.
The Engine object is the virtual container in which the environment is described and in which all actions take place.

See Also

Engine Members


Engine Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method BeginScene
Public Method EndScene
Public Method Initialize
Public Method Loaded
Public Method ResetScene
Public Method SetFPS
Public Method SetLimit
Public Method SetLog
Public Method SetPath
Public Method SetScreen
Public Method SetVersion
Public Method UnInitialize
Public Method Unloaded

See Also

Engine Overview


BeginScene Method

Syntax

Visual Basic
Public Sub BeginScene()

See Also

Engine Object


EndScene Method

Syntax

Visual Basic
Public Sub EndScene()

See Also

Engine Object


Initialize Method
hWnd
Width
Height
BPP
Fullscreen

Syntax

Visual Basic
Public Function Initialize( _
   ByVal hWnd As Long, _
   ByVal Width As Long, _
   ByVal Height As Long, _
   ByVal BPP As Long, _
   Optional ByVal Fullscreen As Boolean _
) As Boolean

Parameters

hWnd
Width
Height
BPP
Fullscreen

See Also

Engine Object


Loaded Method

Syntax

Visual Basic
Public Function Loaded() As Boolean

See Also

Engine Object


ResetScene Method

Syntax

Visual Basic
Public Sub ResetScene()

See Also

Engine Object


SetFPS Method
Visible

Syntax

Visual Basic
Public Sub SetFPS( _
   ByVal Visible As Boolean _
)

Parameters

Visible

See Also

Engine Object


SetLimit Method
Limit

Syntax

Visual Basic
Public Sub SetLimit( _
   ByVal Limit As Long _
)

Parameters

Limit

See Also

Engine Object


SetLog Method
Enabled

Syntax

Visual Basic
Public Sub SetLog( _
   ByVal Enabled As Boolean _
)

Parameters

Enabled

See Also

Engine Object


SetPath Method
Path

Syntax

Visual Basic
Public Sub SetPath( _
   ByVal Path As String _
)

Parameters

Path

See Also

Engine Object


SetScreen Method
Full

Syntax

Visual Basic
Public Sub SetScreen( _
   ByVal Full As Boolean _
)

Parameters

Full

See Also

Engine Object


SetVersion Method
Visible

Syntax

Visual Basic
Public Sub SetVersion( _
   ByVal Visible As Boolean _
)

Parameters

Visible

See Also

Engine Object


UnInitialize Method

GameBasic 3D Engine 1.0 For Visual Basic
UnInitialize Method
See Also Send comments on this topic.

Syntax

Visual Basic
Public Function UnInitialize() As Variant

See Also

Engine Object


Unloaded Method

Syntax

Visual Basic
Public Function Unloaded() As Boolean

See Also

Engine Object


Font Object
See Also Members Send comments on this topic.
The Font object controls how all text is observed within the environment.

See Also

Font Members


Font Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Load
Public Method Render

See Also

Font Overview


Load Method
Name
Size
Bold
Italic
Underline
Strikeout

Syntax

Visual Basic
Public Sub Load( _
   ByVal Name As String, _
   ByVal Size As Long, _
   ByVal Bold As Boolean, _
   ByVal Italic As Boolean, _
   ByVal Underline As Boolean, _
   ByVal Strikeout As Boolean _
)

Parameters

Name
Size
Bold
Italic
Underline
Strikeout

See Also

Font Object


Render Method
Text
X
Y
Red
Green
Blue
Alpha

Syntax

Visual Basic
Public Sub Render( _
   ByVal Text As String, _
   ByVal X As Single, _
   ByVal Y As Single, _
   Optional ByVal Red As Single = 1, _
   Optional ByVal Green As Single = 1, _
   Optional ByVal Blue As Single = 1, _
   Optional ByVal Alpha As Single = 1 _
)

Parameters

Text
X
Y
Red
Green
Blue
Alpha

See Also

Font Object


Frustum Object
See Also Members Send comments on this topic.
The Frustum object is a set of pre rendered bounding volumes used to skip the rendering of objects which are outside the camera view.

See Also

Frustum Members


Frustum Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method BoxInFrustum
Public Method CubeInFrustum
Public Method PointInFrustum
Public Method Update
Public Method VolumeInFrustum

See Also

Frustum Overview


BoxInFrustum Method
Vertex1
Vertex2

Syntax

Visual Basic
Public Function BoxInFrustum( _
   ByRef Vertex1 As Vertex3, _
   ByRef Vertex2 As Vertex3 _
) As Boolean

Parameters

Vertex1
Vertex2

See Also

Frustum Object


CubeInFrustum Method
X
Y
Z
Size

Syntax

Visual Basic
Public Function CubeInFrustum( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single, _
   ByVal Size As Single _
) As Boolean

Parameters

X
Y
Z
Size

See Also

Frustum Object


PointInFrustum Method
X
Y
Z
Radius

Syntax

Visual Basic
Public Function PointInFrustum( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single, _
   ByVal Radius As Single _
) As Boolean

Parameters

X
Y
Z
Radius

See Also

Frustum Object


Update Method

Syntax

Visual Basic
Public Sub Update()

See Also

Frustum Object


VolumeInFrustum Method
Volume

Syntax

Visual Basic
Public Function VolumeInFrustum( _
   ByRef Volume() As Volume_Type _
) As Long

Parameters

Volume

See Also

Frustum Object


Joystick Object
See Also Members Send comments on this topic.
The Joystick object is an input control which can control the environment.

See Also

Joystick Members


Joystick Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Update

Public Properties

Public Property Axes
Public Property Button
Public Property POV

See Also

Joystick Overview


Update Method

Syntax

Visual Basic
Public Sub Update()

See Also

Joystick Object


Axes Property

Property type

Read-only property

Syntax

Visual Basic
Public Property Axes() As Vertex4Long

See Also

Joystick Object


Button Property
Control

Property type

Read-only property

Syntax

Visual Basic
Public Property Button( _
   ByVal Control As JOY_CONTROLS _
) As Boolean

Parameters

Control
Value
JOY_BUTTON1
JOY_BUTTON2
JOY_BUTTON3
JOY_BUTTON4
JOY_BUTTON5
JOY_BUTTON6
JOY_BUTTON7
JOY_BUTTON8
JOY_BUTTON9
JOY_BUTTON10
JOY_BUTTON11
JOY_BUTTON12
JOY_BUTTON13
JOY_BUTTON14
JOY_BUTTON15
JOY_BUTTON16
JOY_BUTTON17
JOY_BUTTON18
JOY_BUTTON19
JOY_BUTTON20
JOY_BUTTON21
JOY_BUTTON22
JOY_BUTTON23
JOY_BUTTON24
JOY_BUTTON25
JOY_BUTTON26
JOY_BUTTON27
JOY_BUTTON28
JOY_BUTTON29
JOY_BUTTON30
JOY_BUTTON31
JOY_BUTTON32

See Also

Joystick Object


POV Property
Button

Property type

Read-only property

Syntax

Visual Basic
Public Property POV( _
   ByVal Button As JOY_POV _
) As Boolean

Parameters

Button
Value
JOY_POV_UP
JOY_POV_RIGHT_UP
JOY_POV_RIGHT
JOY_POV_RIGHT_DOWN
JOY_POV_DOWN
JOY_POV_LEFT_DOWN
JOY_POV_LEFT
JOY_POV_LEFT_UP

See Also

Joystick Object


Keyboard Object
See Also Members Send comments on this topic.
The Keyboard object is an input control which can control the environment.

See Also

Keyboard Members


Keyboard Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Check
Public Method Process
Public Method Text

Public Properties

Public Property Buffer
Public Property Button
Public Property Cursor

See Also

Keyboard Overview


Check Method
Button

Syntax

Visual Basic
Public Function Check( _
   ByVal Button As KEYBOARD_CONTROLS _
) As Boolean

Parameters

Button
Value
KEY_0
KEY_1
KEY_2
KEY_3
KEY_4
KEY_5
KEY_6
KEY_7
KEY_8
KEY_9
KEY_A
KEY_B
KEY_C
KEY_D
KEY_E
KEY_F
KEY_G
KEY_H
KEY_I
KEY_J
KEY_K
KEY_L
KEY_M
KEY_N
KEY_O
KEY_P
KEY_Q
KEY_R
KEY_S
KEY_T
KEY_U
KEY_V
KEY_W
KEY_X
KEY_Y
KEY_Z
KEY_F1
KEY_F2
KEY_F3
KEY_F4
KEY_F5
KEY_F6
KEY_F7
KEY_F8
KEY_F9
KEY_F10
KEY_F11
KEY_F12
KEY_F13
KEY_F14
KEY_F15
KEY_F16
KEY_NUMPAD_0
KEY_NUMPAD_1
KEY_NUMPAD_2
KEY_NUMPAD_3
KEY_NUMPAD_4
KEY_NUMPAD_5
KEY_NUMPAD_6
KEY_NUMPAD_7
KEY_NUMPAD_8
KEY_NUMPAD_9
KEY_NUMPAD_DECIMAL
KEY_NUMPAD_DIVIDE
KEY_NUMPAD_MULTIPLY
KEY_NUMPAD_MINUS
KEY_NUMPAD_PLUS
KEY_NUMPAD_ENTER
KEY_UP
KEY_DOWN
KEY_RIGHT
KEY_LEFT
KEY_INSERT
KEY_HOME
KEY_END
KEY_PAGEUP
KEY_PAGEDOWN
KEY_BACKSPACE
KEY_BACKQUOTE
KEY_COMMA
KEY_TAB
KEY_CLEAR
KEY_RETURN
KEY_PAUSE
KEY_PERIOD
KEY_SLASH
KEY_ESCAPE
KEY_SPACE
KEY_DELETE
KEY_NUMLOCK
KEY_CAPSLOCK
KEY_SHIFT
KEY_CTRL
KEY_ALT
KEY_HELP
KEY_PRINT
KEY_MENU

See Also

Keyboard Object


Process Method
Width
Height

Syntax

Visual Basic
Public Function Process( _
   ByVal Width As Long, _
   Optional ByRef Height As Long _
) As Variant

Parameters

Width
Height

See Also

Keyboard Object


Text Method

Syntax

Visual Basic
Public Function Text() As String

See Also

Keyboard Object


Buffer Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Buffer() As String

See Also

Keyboard Object


Button Property
Control

Property type

Read-only property

Syntax

Visual Basic
Public Property Button( _
   ByVal Control As KEYBOARD_CONTROLS _
) As Boolean

Parameters

Control
Value
KEY_0
KEY_1
KEY_2
KEY_3
KEY_4
KEY_5
KEY_6
KEY_7
KEY_8
KEY_9
KEY_A
KEY_B
KEY_C
KEY_D
KEY_E
KEY_F
KEY_G
KEY_H
KEY_I
KEY_J
KEY_K
KEY_L
KEY_M
KEY_N
KEY_O
KEY_P
KEY_Q
KEY_R
KEY_S
KEY_T
KEY_U
KEY_V
KEY_W
KEY_X
KEY_Y
KEY_Z
KEY_F1
KEY_F2
KEY_F3
KEY_F4
KEY_F5
KEY_F6
KEY_F7
KEY_F8
KEY_F9
KEY_F10
KEY_F11
KEY_F12
KEY_F13
KEY_F14
KEY_F15
KEY_F16
KEY_NUMPAD_0
KEY_NUMPAD_1
KEY_NUMPAD_2
KEY_NUMPAD_3
KEY_NUMPAD_4
KEY_NUMPAD_5
KEY_NUMPAD_6
KEY_NUMPAD_7
KEY_NUMPAD_8
KEY_NUMPAD_9
KEY_NUMPAD_DECIMAL
KEY_NUMPAD_DIVIDE
KEY_NUMPAD_MULTIPLY
KEY_NUMPAD_MINUS
KEY_NUMPAD_PLUS
KEY_NUMPAD_ENTER
KEY_UP
KEY_DOWN
KEY_RIGHT
KEY_LEFT
KEY_INSERT
KEY_HOME
KEY_END
KEY_PAGEUP
KEY_PAGEDOWN
KEY_BACKSPACE
KEY_BACKQUOTE
KEY_COMMA
KEY_TAB
KEY_CLEAR
KEY_RETURN
KEY_PAUSE
KEY_PERIOD
KEY_SLASH
KEY_ESCAPE
KEY_SPACE
KEY_DELETE
KEY_NUMLOCK
KEY_CAPSLOCK
KEY_SHIFT
KEY_CTRL
KEY_ALT
KEY_HELP
KEY_PRINT
KEY_MENU

See Also

Keyboard Object


Cursor Property

Property type

Read-only property

Syntax

Visual Basic
Public Property Cursor() As String

See Also

Keyboard Object


Lights Object
See Also Members Send comments on this topic.
The Lights are one of the most crucial aspects of development, and responsible for the main look and feel of the graphical environment.

See Also

Lights Members


Lights Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method BeginShadow
Public Method Disable
Public Method Enable
Public Method EndShadow
Public Method Load
Public Method Move
Public Method Render
Public Method SetAmbient
Public Method SetDiffuse
Public Method SetDirection
Public Method SetDistance
Public Method SetMaterialAmbience
Public Method SetMaterialDiffuse
Public Method SetMaterialEmission
Public Method SetMaterialShine
Public Method SetMaterialSpecular
Public Method SetPlane
Public Method SetPosition
Public Method SetSpecular
Public Method UnLoad

Public Properties

Public Property Position
Public Property Relative
Public Property Rotation

See Also

Lights Overview


BeginShadow Method
Index

Syntax

Visual Basic
Public Sub BeginShadow( _
   Optional ByVal Index As Long _
)

Parameters

Index

See Also

Lights Object


Disable Method

Syntax

Visual Basic
Public Sub Disable()

See Also

Lights Object


Enable Method

Syntax

Visual Basic
Public Sub Enable()

See Also

Lights Object


EndShadow Method
Index

Syntax

Visual Basic
Public Sub EndShadow( _
   Optional ByVal Index As Long _
)

Parameters

Index

See Also

Lights Object


Load Method
Index

Syntax

Visual Basic
Public Sub Load( _
   ByVal Index As Long _
)

Parameters

Index

See Also

Lights Object


Move Method
Index
X
Y
Z

Syntax

Visual Basic
Public Sub Move( _
   ByVal Index As Long, _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

Index
X
Y
Z

See Also

Lights Object


Render Method

Syntax

Visual Basic
Public Sub Render()

See Also

Lights Object


SetAmbient Method
Index
Red
Green
Blue

Syntax

Visual Basic
Public Sub SetAmbient( _
   ByVal Index As Long, _
   ByVal Red As Single, _
   ByVal Green As Single, _
   ByVal Blue As Single _
)

Parameters

Index
Red
Green
Blue

See Also

Lights Object


SetDiffuse Method
Index
Red
Green
Blue

Syntax

Visual Basic
Public Sub SetDiffuse( _
   ByVal Index As Long, _
   ByVal Red As Single, _
   ByVal Green As Single, _
   ByVal Blue As Single _
)

Parameters

Index
Red
Green
Blue

See Also

Lights Object


SetDirection Method
Index
X
Y
Z

Syntax

Visual Basic
Public Sub SetDirection( _
   ByVal Index As Long, _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

Index
X
Y
Z

See Also

Lights Object


SetDistance Method
Index
Distance

Syntax

Visual Basic
Public Sub SetDistance( _
   ByVal Index As Long, _
   ByVal Distance As Single _
)

Parameters

Index
Distance

See Also

Lights Object


SetMaterialAmbience Method
Index
Red
Green
Blue
Alpha

Syntax

Visual Basic
Public Sub SetMaterialAmbience( _
   ByVal Index As Long, _
   ByVal Red As Single, _
   ByVal Green As Single, _
   ByVal Blue As Single, _
   ByVal Alpha As Single _
)

Parameters

Index
Red
Green
Blue
Alpha

See Also

Lights Object


SetMaterialDiffuse Method
Index
Red
Green
Blue
Alpha

Syntax

Visual Basic
Public Sub SetMaterialDiffuse( _
   ByVal Index As Long, _
   ByVal Red As Single, _
   ByVal Green As Single, _
   ByVal Blue As Single, _
   ByVal Alpha As Single _
)

Parameters

Index
Red
Green
Blue
Alpha

See Also

Lights Object


SetMaterialEmission Method
Index
Red
Green
Blue
Alpha

Syntax

Visual Basic
Public Sub SetMaterialEmission( _
   ByVal Index As Long, _
   ByVal Red As Single, _
   ByVal Green As Single, _
   ByVal Blue As Single, _
   ByVal Alpha As Single _
)

Parameters

Index
Red
Green
Blue
Alpha

See Also

Lights Object


SetMaterialShine Method
Index
Shine

Syntax

Visual Basic
Public Sub SetMaterialShine( _
   ByVal Index As Long, _
   ByRef Shine As Single _
)

Parameters

Index
Shine

See Also

Lights Object


SetMaterialSpecular Method
Index
Red
Green
Blue
Alpha

Syntax

Visual Basic
Public Sub SetMaterialSpecular( _
   ByVal Index As Long, _
   ByVal Red As Single, _
   ByVal Green As Single, _
   ByVal Blue As Single, _
   ByVal Alpha As Single _
)

Parameters

Index
Red
Green
Blue
Alpha

See Also

Lights Object


SetPlane Method
Index
X
Y
Z

Syntax

Visual Basic
Public Sub SetPlane( _
   ByVal Index As Long, _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

Index
X
Y
Z

See Also

Lights Object


SetPosition Method
Index
X
Y
Z

Syntax

Visual Basic
Public Sub SetPosition( _
   ByVal Index As Long, _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

Index
X
Y
Z

See Also

Lights Object


SetSpecular Method
Index
Red
Green
Blue

Syntax

Visual Basic
Public Sub SetSpecular( _
   ByVal Index As Long, _
   ByVal Red As Single, _
   ByVal Green As Single, _
   ByVal Blue As Single _
)

Parameters

Index
Red
Green
Blue

See Also

Lights Object


UnLoad Method

GameBasic 3D Engine 1.0 For Visual Basic
UnLoad Method
See Also Send comments on this topic.
Index

Syntax

Visual Basic
Public Sub UnLoad( _
   ByVal Index As Long _
)

Parameters

Index

See Also

Lights Object


Position Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Position() As Vertex3

See Also

Lights Object


Relative Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Relative() As Boolean

See Also

Lights Object


Rotation Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Rotation() As Vertex3

See Also

Lights Object


Map Object
See Also Members Send comments on this topic.
The Map object is a Binary Spacing Partition format which provides the main building blocks of the environment.

See Also

Map Members


Map Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Load
Public Method Render
Public Method UnLoad

Public Properties

Public Property Collision
Public Property Entities
Public Property Entity
Public Property Plane
Public Property Planes
Public Property Shader
Public Property Visible
Public Property Volume

See Also

Map Overview


Load Method
Filename

Syntax

Visual Basic
Public Sub Load( _
   ByVal Filename As String _
)

Parameters

Filename

See Also

Map Object


Render Method

Syntax

Visual Basic
Public Sub Render()

See Also

Map Object


UnLoad Method

Syntax

Visual Basic
Public Sub UnLoad()

See Also

Map Object


Collision Property
Position
Destination
Offset

Property type

Read-only property

Syntax

Visual Basic
Public Property Collision( _
   ByRef Position As Vertex3, _
   ByRef Destination As Vertex3, _
   Optional ByVal Offset As Single _
) As Collision_Type

Parameters

Position
Destination
Offset

See Also

Map Object


Entities Property

Property type

Read-only property

Syntax

Visual Basic
Public Property Entities() As Long

See Also

Map Object


Entity Property
Index

Property type

Read-only property

Syntax

Visual Basic
Public Property Entity( _
   ByVal Index As Long _
) As Entity_Type

Parameters

Index

See Also

Map Object


Plane Property
Index

Property type

Read-only property

Syntax

Visual Basic
Public Property Plane( _
   ByVal Index As Long _
) As Plane_Type

Parameters

Index

See Also

Map Object


Planes Property

Property type

Read-only property

Syntax

Visual Basic
Public Property Planes() As Long

See Also

Map Object


Shader Property
Name

Property type

Read-write property

Syntax

Visual Basic
Public Property Shader( _
   ByVal Name As String _
) As Shader_Type

Parameters

Name

See Also

Map Object


Visible Property
Position

Property type

Read-only property

Syntax

Visual Basic
Public Property Visible( _
   ByRef Position As Vertex3 _
) As Boolean

Parameters

Position

See Also

Map Object


Volume Property
Volume

Property type

Write-only property

Syntax

Visual Basic
Public Property Volume( _
   ByRef Volume() As Volume_Type _
) As Volume_Type

Parameters

Volume

See Also

Map Object


MD2 Object
See Also Members Send comments on this topic.
The MD2 object is the Quake II model format.

See Also

MD2 Members


MD2 Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Load
Public Method Move
Public Method Render
Public Method Rotate
Public Method SetAnimation
Public Method SetFrame
Public Method SetPosition
Public Method SetRelative
Public Method SetRotation
Public Method SetScale
Public Method SetShader
Public Method SetVelocity
Public Method UnLoad

Public Properties

Public Property Frame
Public Property Position
Public Property Relative
Public Property Rotation
Public Property Shader
Public Property Volume

See Also

MD2 Overview


Load Method
Filename

Syntax

Visual Basic
Public Sub Load( _
   ByVal Filename As String _
)

Parameters

Filename

See Also

MD2 Object


Move Method
X
Y
Z

Syntax

Visual Basic
Public Sub Move( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MD2 Object


Render Method
Animate

Syntax

Visual Basic
Public Sub Render( _
   Optional ByVal Animate As Boolean = True _
)

Parameters

Animate

See Also

MD2 Object


Rotate Method
X
Y
Z

Syntax

Visual Basic
Public Sub Rotate( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MD2 Object


SetAnimation Method
Animation

Syntax

Visual Basic
Public Sub SetAnimation( _
   ByVal Animation As String _
)

Parameters

Animation

See Also

MD2 Object


SetFrame Method
Index

Syntax

Visual Basic
Public Sub SetFrame( _
   ByVal Index As Long _
)

Parameters

Index

See Also

MD2 Object


SetPosition Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetPosition( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MD2 Object


SetRelative Method
Enabled

Syntax

Visual Basic
Public Sub SetRelative( _
   ByVal Enabled As Boolean _
)

Parameters

Enabled

See Also

MD2 Object


SetRotation Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetRotation( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MD2 Object


SetScale Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetScale( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MD2 Object


SetShader Method
Shader

Syntax

Visual Basic
Public Sub SetShader( _
   ByRef Shader As Shader_Type _
)

Parameters

Shader

See Also

MD2 Object


SetVelocity Method
Value

Syntax

Visual Basic
Public Sub SetVelocity( _
   ByVal Value As Single _
)

Parameters

Value

See Also

MD2 Object


UnLoad Method

Syntax

Visual Basic
Public Sub UnLoad()

See Also

MD2 Object


Frame Property

Property type

Read-only property

Syntax

Visual Basic
Public Property Frame() As Long

See Also

MD2 Object


Position Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Position() As Vertex3

See Also

MD2 Object


Relative Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Relative() As Boolean

See Also

MD2 Object


Rotation Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Rotation() As Vertex3

See Also

MD2 Object


Shader Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Shader() As Shader_Type

See Also

MD2 Object


Volume Property

Property type

Read-only property

Syntax

Visual Basic
Public Property Volume() As Volume_Type()

See Also

MD2 Object


MD3 Object
See Also Members Send comments on this topic.
The MD3 object is the Quake III model format.

See Also

MD3 Members


MD3 Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Load
Public Method LoadAnimationTable
Public Method Move
Public Method Render
Public Method Rotate
Public Method SetDeathAnimation
Public Method SetFrame
Public Method SetLegsAnimation
Public Method SetPosition
Public Method SetRelative
Public Method SetRotation
Public Method SetScale
Public Method SetShader
Public Method SetTorsoAnimation
Public Method UnLoad

Public Properties

Public Property Frame
Public Property Position
Public Property Relative
Public Property Rotation
Public Property Shader
Public Property Volume

See Also

MD3 Overview


Load Method
Path
Filename

Syntax

Visual Basic
Public Sub Load( _
   ByVal Path As String, _
   Optional ByVal Filename As String _
)

Parameters

Path
Filename

See Also

MD3 Object


LoadAnimationTable Method
Filename

Syntax

Visual Basic
Public Sub LoadAnimationTable( _
   ByVal Filename As String _
)

Parameters

Filename

See Also

MD3 Object


Move Method
X
Y
Z

Syntax

Visual Basic
Public Sub Move( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MD3 Object


Render Method
Animate

Syntax

Visual Basic
Public Sub Render( _
   Optional ByVal Animate As Boolean = True _
)

Parameters

Animate

See Also

MD3 Object


Rotate Method
X
Y
Z

Syntax

Visual Basic
Public Sub Rotate( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MD3 Object


SetDeathAnimation Method
Name

Syntax

Visual Basic
Public Sub SetDeathAnimation( _
   ByVal Name As MD3_Death_Animations _
)

Parameters

Name
Value
BOTH_DEATH1
BOTH_DEAD1
BOTH_DEATH2
BOTH_DEAD2
BOTH_DEATH3
BOTH_DEAD3

See Also

MD3 Object


SetFrame Method
Index
Model

Syntax

Visual Basic
Public Sub SetFrame( _
   ByVal Index As Long, _
   ByRef Model As MD3_Models _
)

Parameters

Index
Model
Value
MD3_LOWER
MD3_UPPER
MD3_HEAD
MD3_WEAPON

See Also

MD3 Object


SetLegsAnimation Method
Name

Syntax

Visual Basic
Public Sub SetLegsAnimation( _
   ByVal Name As MD3_Legs_Animations _
)

Parameters

Name
Value
LEGS_WALKCR
LEGS_WALK
LEGS_RUN
LEGS_BACK
LEGS_SWIM
LEGS_JUMP
LEGS_LAND
LEGS_JUMPB
LEGS_LANDB
LEGS_IDLE
LEGS_IDLECR
LEGS_TURN

See Also

MD3 Object


SetPosition Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetPosition( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MD3 Object


SetRelative Method
Enabled

Syntax

Visual Basic
Public Sub SetRelative( _
   ByVal Enabled As Boolean _
)

Parameters

Enabled

See Also

MD3 Object


SetRotation Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetRotation( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MD3 Object


SetScale Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetScale( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MD3 Object


SetShader Method
Index
Shader

Syntax

Visual Basic
Public Sub SetShader( _
   ByVal Index As Long, _
   ByRef Shader As Shader_Type _
)

Parameters

Index
Shader

See Also

MD3 Object


SetTorsoAnimation Method
Name

Syntax

Visual Basic
Public Sub SetTorsoAnimation( _
   ByVal Name As MD3_Torso_Animations _
)

Parameters

Name
Value
TORSO_GESTURE
TORSO_ATTACK
TORSO_ATTACK2
TORSO_DROP
TORSO_RAISE
TORSO_STAND
TORSO_STAND2

See Also

MD3 Object


UnLoad Method

Syntax

Visual Basic
Public Sub UnLoad()

See Also

MD3 Object


Frame Property
Model

Property type

Read-only property

Syntax

Visual Basic
Public Property Frame( _
   ByVal Model As MD3_Models _
) As Long

Parameters

Model
Value
MD3_LOWER
MD3_UPPER
MD3_HEAD
MD3_WEAPON

See Also

MD3 Object


Position Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Position() As Vertex3

See Also

MD3 Object


Relative Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Relative() As Boolean

See Also

MD3 Object


Rotation Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Rotation() As Vertex3

See Also

MD3 Object


Shader Property
Index

Property type

Read-write property

Syntax

Visual Basic
Public Property Shader( _
   ByVal Index As Long _
) As Shader_Type

Parameters

Index

See Also

MD3 Object


Volume Property
Index

Property type

Read-only property

Syntax

Visual Basic
Public Property Volume( _
   Optional ByRef Index As Long = -1 _
) As Volume_Type()

Parameters

Index

See Also

MD3 Object


MD5 Object
See Also Members Send comments on this topic.
The MD5 object is Doom III and Quake IV model format.

See Also

MD5 Members


MD5 Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Load
Public Method LoadAnimation
Public Method LoadCamera
Public Method Move
Public Method Render
Public Method Rotate
Public Method SetAnimation
Public Method SetFrame
Public Method SetPosition
Public Method SetRelative
Public Method SetRotation
Public Method SetScale
Public Method UnLoad
Public Method Update

Public Properties

Public Property Camera
Public Property Cameras
Public Property Frame
Public Property Joint
Public Property Joints
Public Property Position
Public Property Relative
Public Property Rotation
Public Property Shader
Public Property Volume

See Also

MD5 Overview


Load Method
Filename

Syntax

Visual Basic
Public Sub Load( _
   ByVal Filename As String _
)

Parameters

Filename

See Also

MD5 Object


LoadAnimation Method
Filename

Syntax

Visual Basic
Public Sub LoadAnimation( _
   ByVal Filename As String _
)

Parameters

Filename

See Also

MD5 Object


LoadCamera Method
Filename

Syntax

Visual Basic
Public Sub LoadCamera( _
   ByVal Filename As String _
)

Parameters

Filename

See Also

MD5 Object


Move Method
X
Y
Z

Syntax

Visual Basic
Public Sub Move( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MD5 Object


Render Method
Animate

Syntax

Visual Basic
Public Sub Render( _
   Optional ByVal Animate As Boolean = True _
)

Parameters

Animate

See Also

MD5 Object


Rotate Method
X
Y
Z

Syntax

Visual Basic
Public Sub Rotate( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MD5 Object


SetAnimation Method
Animation
Blend

Syntax

Visual Basic
Public Sub SetAnimation( _
   ByVal Animation As String, _
   Optional ByRef Blend As Single = 1 _
)

Parameters

Animation
Blend

See Also

MD5 Object


SetFrame Method
Frame

Syntax

Visual Basic
Public Sub SetFrame( _
   ByVal Frame As Long _
)

Parameters

Frame

See Also

MD5 Object


SetPosition Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetPosition( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MD5 Object


SetRelative Method
Enabled

Syntax

Visual Basic
Public Sub SetRelative( _
   ByVal Enabled As Boolean _
)

Parameters

Enabled

See Also

MD5 Object


SetRotation Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetRotation( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MD5 Object


SetScale Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetScale( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MD5 Object


UnLoad Method

Syntax

Visual Basic
Public Sub UnLoad()

See Also

MD5 Object


Update Method

Syntax

Visual Basic
Public Sub Update()

See Also

MD5 Object


Camera Property
Index

Property type

Read-only property

Syntax

Visual Basic
Public Property Camera( _
   ByVal Index As Long _
) As Camera_Type

Parameters

Index

See Also

MD5 Object


Cameras Property

Property type

Read-only property

Syntax

Visual Basic
Public Property Cameras() As Long

See Also

MD5 Object


Frame Property

Property type

Read-only property

Syntax

Visual Basic
Public Property Frame() As Long

See Also

MD5 Object


Joint Property
Index

Property type

Read-write property

Syntax

Visual Basic
Public Property Joint( _
   ByVal Index As Long _
) As Joint_Type

Parameters

Index

See Also

MD5 Object


Joints Property

Property type

Read-only property

Syntax

Visual Basic
Public Property Joints() As Long

See Also

MD5 Object


Position Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Position() As Vertex3

See Also

MD5 Object


Relative Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Relative() As Boolean

See Also

MD5 Object


Rotation Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Rotation() As Vertex3

See Also

MD5 Object


Shader Property
Name

Property type

Read-write property

Syntax

Visual Basic
Public Property Shader( _
   ByVal Name As String _
) As Shader_Type

Parameters

Name

See Also

MD5 Object


Volume Property
Index

Property type

Read-only property

Syntax

Visual Basic
Public Property Volume( _
   Optional ByRef Index As Long _
) As Volume_Type()

Parameters

Index

See Also

MD5 Object


MDL Object
See Also Members Send comments on this topic.
The MDL object is the Quake model format.

See Also

MDL Members


MDL Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Load
Public Method Move
Public Method Render
Public Method Rotate
Public Method SetAnimation
Public Method SetFrame
Public Method SetPalette
Public Method SetPosition
Public Method SetRelative
Public Method SetRotation
Public Method SetScale
Public Method SetVelocity
Public Method UnLoad

Public Properties

Public Property Frame
Public Property Position
Public Property Relative
Public Property Rotation
Public Property Shader
Public Property Volume

See Also

MDL Overview


Load Method
Filename

Syntax

Visual Basic
Public Sub Load( _
   ByVal Filename As String _
)

Parameters

Filename

See Also

MDL Object


Move Method
X
Y
Z

Syntax

Visual Basic
Public Sub Move( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MDL Object


Render Method
Animate

Syntax

Visual Basic
Public Sub Render( _
   Optional ByVal Animate As Boolean = True _
)

Parameters

Animate

See Also

MDL Object


Rotate Method
X
Y
Z

Syntax

Visual Basic
Public Sub Rotate( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MDL Object


SetAnimation Method
Animation

Syntax

Visual Basic
Public Sub SetAnimation( _
   ByVal Animation As String _
)

Parameters

Animation

See Also

MDL Object


SetFrame Method
Index

Syntax

Visual Basic
Public Sub SetFrame( _
   ByVal Index As Long _
)

Parameters

Index

See Also

MDL Object


SetPalette Method
Filename

Syntax

Visual Basic
Public Sub SetPalette( _
   ByVal Filename As String _
)

Parameters

Filename

See Also

MDL Object


SetPosition Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetPosition( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MDL Object


SetRelative Method
Enabled

Syntax

Visual Basic
Public Sub SetRelative( _
   ByVal Enabled As Boolean _
)

Parameters

Enabled

See Also

MDL Object


SetRotation Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetRotation( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MDL Object


SetScale Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetScale( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

MDL Object


SetVelocity Method
Value

Syntax

Visual Basic
Public Sub SetVelocity( _
   ByVal Value As Single _
)

Parameters

Value

See Also

MDL Object


UnLoad Method

Syntax

Visual Basic
Public Sub UnLoad()

See Also

MDL Object


Frame Property

Property type

Read-only property

Syntax

Visual Basic
Public Property Frame() As Long

See Also

MDL Object


Position Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Position() As Vertex3

See Also

MDL Object


Relative Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Relative() As Boolean

See Also

MDL Object


Rotation Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Rotation() As Vertex3

See Also

MDL Object


Shader Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Shader() As Shader_Type

See Also

MDL Object


Volume Property

Property type

Read-only property

Syntax

Visual Basic
Public Property Volume() As Volume_Type()

See Also

MDL Object


Mesh Object
See Also Members Send comments on this topic.
The Mesh object is used to create physical objects not usually created by other formats.

See Also

Mesh Members


Mesh Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Load
Public Method Move
Public Method Render
Public Method Rotate
Public Method SetPosition
Public Method SetRelative
Public Method SetRotation
Public Method SetScale
Public Method SetShader
Public Method SetTriangle
Public Method SetVertex
Public Method UnLoad

Public Properties

Public Property Normal
Public Property Position
Public Property Relative
Public Property Rotation
Public Property Shader
Public Property Texture
Public Property Vertex
Public Property Vertices
Public Property Volume

See Also

Mesh Overview


Load Method
Filename

Syntax

Visual Basic
Public Sub Load( _
   ByVal Filename As String _
)

Parameters

Filename

See Also

Mesh Object


Move Method
X
Y
Z

Syntax

Visual Basic
Public Sub Move( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Mesh Object


Render Method

Syntax

Visual Basic
Public Function Render() As Variant

See Also

Mesh Object


Rotate Method
X
Y
Z

Syntax

Visual Basic
Public Sub Rotate( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Mesh Object


SetPosition Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetPosition( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Mesh Object


SetRelative Method
Enabled

Syntax

Visual Basic
Public Sub SetRelative( _
   ByVal Enabled As Boolean _
)

Parameters

Enabled

See Also

Mesh Object


SetRotation Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetRotation( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Mesh Object


SetScale Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetScale( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Mesh Object


SetShader Method
Index
Shader

Syntax

Visual Basic
Public Sub SetShader( _
   ByVal Index As Long, _
   ByRef Shader As Shader_Type _
)

Parameters

Index
Shader

See Also

Mesh Object


SetTriangle Method
Index
X
Y
Z

Syntax

Visual Basic
Public Sub SetTriangle( _
   ByVal Index As Long, _
   ByVal X As Long, _
   ByVal Y As Long, _
   ByVal Z As Long _
)

Parameters

Index
X
Y
Z

See Also

Mesh Object


SetVertex Method
Index
X
Y
Z
U
V

Syntax

Visual Basic
Public Sub SetVertex( _
   ByVal Index As Long, _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single, _
   Optional ByVal U As Single = -1, _
   Optional ByVal V As Single = -1 _
)

Parameters

Index
X
Y
Z
U
V

See Also

Mesh Object


UnLoad Method

Syntax

Visual Basic
Public Sub UnLoad()

See Also

Mesh Object


Normal Property
Index
Vertice

Property type

Read-write property

Syntax

Visual Basic
Public Property Normal( _
   Optional ByVal Index As Long, _
   Optional ByVal Vertice As Long _
) As Vertex3

Parameters

Index
Vertice

See Also

Mesh Object


Position Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Position() As Vertex3

See Also

Mesh Object


Relative Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Relative() As Boolean

See Also

Mesh Object


Rotation Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Rotation() As Vertex3

See Also

Mesh Object


Shader Property
Name

Property type

Read-write property

Syntax

Visual Basic
Public Property Shader( _
   ByVal Name As String _
) As Shader_Type

Parameters

Name

See Also

Mesh Object


Texture Property
Index
Vertice

Property type

Read-write property

Syntax

Visual Basic
Public Property Texture( _
   Optional ByVal Index As Long, _
   Optional ByVal Vertice As Long _
) As Vertex2

Parameters

Index
Vertice

See Also

Mesh Object


Vertex Property
Index
Vertice

Property type

Read-write property

Syntax

Visual Basic
Public Property Vertex( _
   Optional ByVal Index As Long, _
   Optional ByVal Vertice As Long _
) As Vertex3

Parameters

Index
Vertice

See Also

Mesh Object


Vertices Property
Index

Property type

Read-only property

Syntax

Visual Basic
Public Property Vertices( _
   ByVal Index As Long _
) As Variant

Parameters

Index

See Also

Mesh Object


Volume Property
Index

Property type

Read-only property

Syntax

Visual Basic
Public Property Volume( _
   Optional ByVal Index As Long = -1 _
) As Volume_Type()

Parameters

Index

See Also

Mesh Object


Pack Object
See Also Members Send comments on this topic.
The Pack object is the Quake archive format used to compress and store multiple files.

See Also

Pack Members


Pack Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Clean
Public Method Extract
Public Method Load
Public Method UnLoad

See Also

Pack Overview


Clean Method

Syntax

Visual Basic
Public Sub Clean()

See Also

Pack Object


Extract Method
Filename

Syntax

Visual Basic
Public Function Extract( _
   Optional ByVal Filename As String _
) As Boolean

Parameters

Filename

See Also

Pack Object


Load Method
Filename

Syntax

Visual Basic
Public Sub Load( _
   ByVal Filename As String _
)

Parameters

Filename

See Also

Pack Object


UnLoad Method

Syntax

Visual Basic
Public Sub UnLoad()

See Also

Pack Object


Particles Object
See Also Members Send comments on this topic.
The Particles object is used to create the illusion of a real world effects within the environment.

See Also

Particles Members


Particles Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Load
Public Method Move
Public Method Render
Public Method Rotate
Public Method SetColor
Public Method SetDeath
Public Method SetDestination
Public Method SetDirection
Public Method SetFriction
Public Method SetGravity
Public Method SetLife
Public Method SetOrigin
Public Method SetPosition
Public Method SetRate
Public Method SetRelative
Public Method SetRotation
Public Method SetScale
Public Method SetShader
Public Method SetVelocity
Public Method UnLoad
Public Method Update

Public Properties

Public Property Color
Public Property Count
Public Property Death
Public Property Decal
Public Property Destination
Public Property Direction
Public Property Distance
Public Property Emission
Public Property Friction
Public Property Gravity
Public Property Life
Public Property Normal
Public Property Origin
Public Property Position
Public Property Relative
Public Property Rotation
Public Property Shader
Public Property Size
Public Property Tag
Public Property Velocity
Public Property Visible
Public Property Volume

See Also

Particles Overview


Load Method
Count

Syntax

Visual Basic
Public Sub Load( _
   ByVal Count As Long _
)

Parameters

Count

See Also

Particles Object


Move Method
X
Y
Z

Syntax

Visual Basic
Public Sub Move( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Particles Object


Render Method

Syntax

Visual Basic
Public Sub Render()

See Also

Particles Object


Rotate Method
X
Y
Z

Syntax

Visual Basic
Public Sub Rotate( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Particles Object


SetColor Method
Index
Red
Green
Blue

Syntax

Visual Basic
Public Sub SetColor( _
   Optional ByVal Index As Long, _
   Optional ByVal Red As Single, _
   Optional ByVal Green As Single, _
   Optional ByVal Blue As Single _
)

Parameters

Index
Red
Green
Blue

See Also

Particles Object


SetDeath Method
Death

Syntax

Visual Basic
Public Sub SetDeath( _
   ByVal Death As Single _
)

Parameters

Death

See Also

Particles Object


SetDestination Method
Index
X
Y
Z

Syntax

Visual Basic
Public Sub SetDestination( _
   Optional ByVal Index As Long, _
   Optional ByVal X As Single, _
   Optional ByVal Y As Single, _
   Optional ByVal Z As Single _
)

Parameters

Index
X
Y
Z

See Also

Particles Object


SetDirection Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetDirection( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Particles Object


SetFriction Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetFriction( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Particles Object


SetGravity Method
Value

Syntax

Visual Basic
Public Sub SetGravity( _
   ByVal Value As Single _
)

Parameters

Value

See Also

Particles Object


SetLife Method
Value

Syntax

Visual Basic
Public Sub SetLife( _
   ByVal Value As Single _
)

Parameters

Value

See Also

Particles Object


SetOrigin Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetOrigin( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Particles Object


SetPosition Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetPosition( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Particles Object


SetRate Method
Seconds

Syntax

Visual Basic
Public Sub SetRate( _
   ByVal Seconds As Single _
)

Parameters

Seconds

See Also

Particles Object


SetRelative Method
Enabled

Syntax

Visual Basic
Public Sub SetRelative( _
   ByVal Enabled As Boolean _
)

Parameters

Enabled

See Also

Particles Object


SetRotation Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetRotation( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Particles Object


SetScale Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetScale( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Particles Object


SetShader Method
Shader

Syntax

Visual Basic
Public Sub SetShader( _
   ByRef Shader As Shader_Type _
)

Parameters

Shader

See Also

Particles Object


SetVelocity Method
Value

Syntax

Visual Basic
Public Sub SetVelocity( _
   ByVal Value As Single _
)

Parameters

Value

See Also

Particles Object


UnLoad Method

Syntax

Visual Basic
Public Sub UnLoad()

See Also

Particles Object


Update Method

Syntax

Visual Basic
Public Sub Update()

See Also

Particles Object


Color Property
Index

Property type

Read-write property

Syntax

Visual Basic
Public Property Color( _
   Optional ByVal Index As Long _
) As Vertex3

Parameters

Index

See Also

Particles Object


Count Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

See Also

Particles Object


Death Property
Index

Property type

Read-write property

Syntax

Visual Basic
Public Property Death( _
   Optional ByVal Index As Long _
) As Single

Parameters

Index

See Also

Particles Object


Decal Property
Index

Property type

Read-write property

Syntax

Visual Basic
Public Property Decal( _
   Optional ByVal Index As Long _
) As Boolean

Parameters

Index

See Also

Particles Object


Destination Property
Index

Property type

Read-write property

Syntax

Visual Basic
Public Property Destination( _
   Optional ByVal Index As Long _
) As Vertex3

Parameters

Index

See Also

Particles Object


Direction Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Direction() As Vertex3

See Also

Particles Object


Distance Property

Property type

Read-only property

Syntax

Visual Basic
Public Property Distance() As Vertex3

See Also

Particles Object


Emission Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Emission() As Boolean

See Also

Particles Object


Friction Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Friction() As Vertex3

See Also

Particles Object


Gravity Property
Index

Property type

Read-write property

Syntax

Visual Basic
Public Property Gravity( _
   Optional ByVal Index As Long _
) As Single

Parameters

Index

See Also

Particles Object


Life Property
Index

Property type

Read-write property

Syntax

Visual Basic
Public Property Life( _
   Optional ByVal Index As Long _
) As Single

Parameters

Index

See Also

Particles Object


Normal Property
Index

Property type

Read-write property

Syntax

Visual Basic
Public Property Normal( _
   Optional ByVal Index As Long _
) As Vertex3

Parameters

Index

See Also

Particles Object


Origin Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Origin() As Vertex3

See Also

Particles Object


Position Property
Index

Property type

Read-write property

Syntax

Visual Basic
Public Property Position( _
   Optional ByVal Index As Long _
) As Vertex3

Parameters

Index

See Also

Particles Object


Relative Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Relative() As Boolean

See Also

Particles Object


Rotation Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Rotation() As Vertex3

See Also

Particles Object


Shader Property
Index

Property type

Read-write property

Syntax

Visual Basic
Public Property Shader( _
   Optional ByVal Index As Long _
) As Shader_Type

Parameters

Index

See Also

Particles Object


Size Property
Index

Property type

Read-write property

Syntax

Visual Basic
Public Property Size( _
   Optional ByVal Index As Long _
) As Single

Parameters

Index

See Also

Particles Object


Tag Property
Index

Property type

Read-write property

Syntax

Visual Basic
Public Property Tag( _
   Optional ByVal Index As Long _
) As Boolean

Parameters

Index

See Also

Particles Object


Velocity Property

Property type

Read-only property

Syntax

Visual Basic
Public Property Velocity() As Single

See Also

Particles Object


Visible Property
Index

Property type

Read-write property

Syntax

Visual Basic
Public Property Visible( _
   Optional ByVal Index As Long _
) As Boolean

Parameters

Index

See Also

Particles Object


Volume Property
Index

Property type

Read-only property

Syntax

Visual Basic
Public Property Volume( _
   Optional ByRef Index As Long _
) As Volume_Type()

Parameters

Index

See Also

Particles Object


Physics Object
See Also Members Send comments on this topic.
The Physics object is responsible for the movement of objects within the environment relative to the laws of physics.

See Also

Physics Members


Physics Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Move
Public Method Rotate
Public Method SetDestination
Public Method SetDirection
Public Method SetFriction
Public Method SetGravity
Public Method SetGround
Public Method SetPosition
Public Method SetRotation
Public Method SetWeight
Public Method Update

Public Properties

Public Property Destination
Public Property Direction
Public Property Gravity
Public Property Ground
Public Property Position
Public Property Rotation
Public Property Velocity
Public Property Weight

See Also

Physics Overview


Move Method
X
Y
Z

Syntax

Visual Basic
Public Sub Move( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Physics Object


Rotate Method
X
Y
Z

Syntax

Visual Basic
Public Sub Rotate( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Physics Object


SetDestination Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetDestination( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Physics Object


SetDirection Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetDirection( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Physics Object


SetFriction Method
Force

Syntax

Visual Basic
Public Sub SetFriction( _
   ByVal Force As Single _
)

Parameters

Force

See Also

Physics Object


SetGravity Method
Force

Syntax

Visual Basic
Public Sub SetGravity( _
   ByVal Force As Single _
)

Parameters

Force

See Also

Physics Object


SetGround Method
Ground

Syntax

Visual Basic
Public Sub SetGround( _
   ByVal Ground As Single _
)

Parameters

Ground

See Also

Physics Object


SetPosition Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetPosition( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Physics Object


SetRotation Method
X
Y
Z

Syntax

Visual Basic
Public Sub SetRotation( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)

Parameters

X
Y
Z

See Also

Physics Object


SetWeight Method
Weight

Syntax

Visual Basic
Public Sub SetWeight( _
   ByVal Weight As Single _
)

Parameters

Weight

See Also

Physics Object


Update Method

Syntax

Visual Basic
Public Sub Update()

See Also

Physics Object


Destination Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Destination() As Vertex3

See Also

Physics Object


Direction Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Direction() As Vertex3

See Also

Physics Object


Gravity Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Gravity() As Single

See Also

Physics Object


Ground Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Ground() As Single

See Also

Physics Object


Position Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Position() As Vertex3

See Also

Physics Object


Rotation Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Rotation() As Vertex3

See Also

Physics Object


Velocity Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Velocity() As Single

See Also

Physics Object


Weight Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Weight() As Single

See Also

Physics Object


Programs Object
See Also Members Send comments on this topic.
The Programs object is responsable for the OpenGL Shading Language (GLSL), and used to manipulate the graphical objects within the environment.

See Also

Programs Members


Programs Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Link
Public Method Load
Public Method SetUniformTexture
Public Method SetUniformVariable1
Public Method SetUniformVariable2
Public Method SetUniformVariable3
Public Method SetUniformVariable4

See Also

Programs Overview


Link Method
Vertex
Fragment

Syntax

Visual Basic
Public Function Link( _
   ByVal Vertex As Long, _
   ByVal Fragment As Long _
) As Long

Parameters

Vertex
Fragment

See Also

Programs Object


Load Method
Shader
Object

Syntax

Visual Basic
Public Function Load( _
   ByVal Shader As String, _
   ByVal Object As SHADER_OBJECT _
) As Long

Parameters

Shader
Object

See Also

Programs Object


SetUniformTexture Method

GameBasic 3D Engine 1.0 For Visual Basic
SetUniformTexture Method
See Also Send comments on this topic.
Index
Name
Unit

Syntax

Visual Basic
Public Sub SetUniformTexture( _
   ByVal Index As Long, _
   ByVal Name As String, _
   ByVal Unit As Long _
)

Parameters

Index
Name
Unit

See Also

Programs Object


SetUniformVariable1 Method

GameBasic 3D Engine 1.0 For Visual Basic
SetUniformVariable1 Method
See Also Send comments on this topic.
Index
Name
Value

Syntax

Visual Basic
Public Sub SetUniformVariable1( _
   ByVal Index As Long, _
   ByVal Name As String, _
   ByVal Value As Single _
)

Parameters

Index
Name
Value

See Also

Programs Object


SetUniformVariable2 Method
Index
Name
Value

Syntax

Visual Basic
Public Sub SetUniformVariable2( _
   ByVal Index As Long, _
   ByVal Name As String, _
   ByRef Value As Vertex2 _
)

Parameters

Index
Name
Value

See Also

Programs Object


SetUniformVariable3 Method
Index
Name
Value

Syntax

Visual Basic
Public Sub SetUniformVariable3( _
   ByVal Index As Long, _
   ByVal Name As String, _
   ByRef Value As Vertex3 _
)

Parameters

Index
Name
Value

See Also

Programs Object


SetUniformVariable4 Method
Index
Name
Value

Syntax

Visual Basic
Public Sub SetUniformVariable4( _
   ByVal Index As Long, _
   ByVal Name As String, _
   ByRef Value As Vertex4 _
)

Parameters

Index
Name
Value

See Also

Programs Object


Shaders Object
See Also Members Send comments on this topic.
The Shaders object is used to manipulate the graphical objects within the environment which affect the appearance, and behaviors.

See Also

Shaders Members


Shaders Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Load
Public Method UnLoad

See Also

Shaders Overview


Load Method
Filename
Name

Syntax

Visual Basic
Public Function Load( _
   ByVal Filename As String, _
   Optional ByVal Name As String _
) As Shader_Type

Parameters

Filename
Name

See Also

Shaders Object


UnLoad Method
Shader

Syntax

Visual Basic
Public Function UnLoad( _
   ByRef Shader As Shader_Type _
) As Variant

Parameters

Shader

See Also

Shaders Object


Sound Object
See Also Members Send comments on this topic.
The Sound object controls all audio within the environment.

See Also

Sound Members


Sound Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Frequency
Public Method Load
Public Method Pause
Public Method Play
Public Method Repeat
Public Method UnLoad
Public Method Volume

See Also

Sound Overview


Frequency Method
Filename
Value

Syntax

Visual Basic
Public Function Frequency( _
   ByVal Filename As String, _
   ByVal Value As Long _
) As Variant

Parameters

Filename
Value

See Also

Sound Object


Load Method
Filename

Syntax

Visual Basic
Public Function Load( _
   ByVal Filename As String _
) As Variant

Parameters

Filename

See Also

Sound Object


Pause Method
Filename

Syntax

Visual Basic
Public Function Pause( _
   ByVal Filename As String _
) As Variant

Parameters

Filename

See Also

Sound Object


Play Method
Filename

Syntax

Visual Basic
Public Function Play( _
   ByVal Filename As String _
) As Variant

Parameters

Filename

See Also

Sound Object


Repeat Method
Filename

Syntax

Visual Basic
Public Function Repeat( _
   ByVal Filename As String _
) As Variant

Parameters

Filename

See Also

Sound Object


UnLoad Method
Filename

Syntax

Visual Basic
Public Function UnLoad( _
   ByVal Filename As String _
) As Variant

Parameters

Filename

See Also

Sound Object


Volume Method
Filename
Value

Syntax

Visual Basic
Public Function Volume( _
   ByVal Filename As String, _
   ByVal Value As Long _
) As Variant

Parameters

Filename
Value

See Also

Sound Object


Timer Object
See Also Members Send comments on this topic.
The Timer is a synchronization object whose state is set to stopped when the specified time arrives.

See Also

Timer Members


Timer Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Stopped

Public Properties

Public Property Interval

See Also

Timer Overview


Stopped Method

Syntax

Visual Basic
Public Function Stopped() As Boolean

See Also

Timer Object


Interval Property

Property type

Read-write property

Syntax

Visual Basic
Public Property Interval() As Single

See Also

Timer Object


Volume Object
See Also Members Send comments on this topic.
The Volume object is the primary collision detection and frustrum culling system used by referencing a bounding box for every physical object within the environment.

See Also

Volume Members


Volume Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Collision
Public Method Cross
Public Method Distance
Public Method Intersect
Public Method Render

See Also

Volume Overview


Collision Method
Volume1
Volume2

Syntax

Visual Basic
Public Function Collision( _
   ByRef Volume1() As Volume_Type, _
   ByRef Volume2() As Volume_Type _
) As Boolean

Parameters

Volume1
Volume2

See Also

Volume Object


Cross Method
Position
Destination
Volume

Syntax

Visual Basic
Public Function Cross( _
   ByRef Position As Vertex3, _
   ByRef Destination As Vertex3, _
   ByRef Volume() As Volume_Type _
) As Boolean

Parameters

Position
Destination
Volume

See Also

Volume Object


Distance Method
Position
Direction
Volume

Syntax

Visual Basic
Public Function Distance( _
   ByRef Position As Vertex3, _
   ByRef Direction As Vertex3, _
   ByRef Volume() As Volume_Type _
) As Vertex3

Parameters

Position
Direction
Volume

See Also

Volume Object


Intersect Method
Position
Offset
Volume

Syntax

Visual Basic
Public Function Intersect( _
   ByRef Position As Vertex3, _
   ByVal Offset As Single, _
   ByRef Volume() As Volume_Type _
) As Boolean

Parameters

Position
Offset
Volume

See Also

Volume Object


Render Method
Volume
Red
Green
Blue

Syntax

Visual Basic
Public Function Render( _
   ByRef Volume() As Volume_Type, _
   Optional ByVal Red As Single = 1, _
   Optional ByVal Green As Single = 1, _
   Optional ByVal Blue As Single = 1 _
) As Variant

Parameters

Volume
Red
Green
Blue

See Also

Volume Object


Window Object
See Also Members Send comments on this topic.
The Window object is used to create and destroy individual windows.

See Also

Window Members


Window Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method Load
Public Method UnLoad

See Also

Window Overview


Load Method
Width
Height
Fullscreen

Syntax

Visual Basic
Public Function Load( _
   ByVal Width As Long, _
   ByVal Height As Long, _
   Optional ByVal Fullscreen As Boolean _
) As Long

Parameters

Width
Height
Fullscreen

See Also

Window Object


UnLoad Method

Syntax

Visual Basic
Public Function UnLoad() As Variant

See Also

Window Object


Camera_Frames
Send comments on this topic.

UDT Members

Member | Type
Position | Vertex3
Rotation | Vertex4
FieldOfView | Single

See Also

Vertex3, Vertex4


Camera_Type
Send comments on this topic.

UDT Members

Member | Type
Name | String
FrameRate | Long
FrameCount | Long
Frames() | Camera_Frames

See Also

Camera_Frames


Collision_Type
Send comments on this topic.

UDT Members

Member | Type
Relative | Boolean
Surface | Long
Ground | Single
Destination | Vertex3
Normal | Vertex3
Position | Vertex3

See Also

Vertex3


CURSOR_CONTROLS Enumeration

Members

Member | Value
MOUSE_LEFT | vbKeyLButton
MOUSE_MIDDLE | vbKeyMButton
MOUSE_RIGHT | vbKeyRButton


Entity_Type
Send comments on this topic.

UDT Members

Member | Type
Angle | Single
Health | Single
Speed | Single
Wait | Single
Model | String
Message | String
Name | String
Noise | String
Target | String
Team | String
Origin | Vertex3

See Also

Vertex3


Joint_Type
Send comments on this topic.

UDT Members

Member | Type
Name | String
Index | Long
Parent | Long
Children() | Long
Position | Vertex3
Rotation | Vertex4

See Also

Vertex3, Vertex4


JOY_POV Enumeration

Members

Member | Value
JOY_POV_UP | 1
JOY_POV_RIGHT_UP | 4501
JOY_POV_RIGHT | 9001
JOY_POV_RIGHT_DOWN | 13501
JOY_POV_DOWN | 18001
JOY_POV_LEFT_DOWN | 22501
JOY_POV_LEFT | 27001
JOY_POV_LEFT_UP | 31501


KEYBOARD_CONTROLS Enumeration

Members

Member | Value
KEY_0 | vbKey0
KEY_1 | vbKey1
KEY_2 | vbKey2
KEY_3 | vbKey3
KEY_4 | vbKey4
KEY_5 | vbKey5
KEY_6 | vbKey6
KEY_7 | vbKey7
KEY_8 | vbKey8
KEY_9 | vbKey9
KEY_A | vbKeyA
KEY_B | vbKeyB
KEY_C | vbKeyC
KEY_D | vbKeyD
KEY_E | vbKeyE
KEY_F | vbKeyF
KEY_G | vbKeyG
KEY_H | vbKeyH
KEY_I | vbKeyI
KEY_J | vbKeyJ
KEY_K | vbKeyK
KEY_L | vbKeyL
KEY_M | vbKeyM
KEY_N | vbKeyN
KEY_O | vbKeyO
KEY_P | vbKeyP
KEY_Q | vbKeyQ
KEY_R | vbKeyR
KEY_S | vbKeyS
KEY_T | vbKeyT
KEY_U | vbKeyU
KEY_V | vbKeyV
KEY_W | vbKeyW
KEY_X | vbKeyX
KEY_Y | vbKeyY
KEY_Z | vbKeyZ
KEY_F1 | vbKeyF1
KEY_F2 | vbKeyF2
KEY_F3 | vbKeyF3
KEY_F4 | vbKeyF4
KEY_F5 | vbKeyF5
KEY_F6 | vbKeyF6
KEY_F7 | vbKeyF7
KEY_F8 | vbKeyF8
KEY_F9 | vbKeyF9
KEY_F10 | vbKeyF10
KEY_F11 | vbKeyF11
KEY_F12 | vbKeyF12
KEY_F13 | vbKeyF13
KEY_F14 | vbKeyF14
KEY_F15 | vbKeyF15
KEY_F16 | vbKeyF16
KEY_NUMPAD_0 | vbKeyNumpad0
KEY_NUMPAD_1 | vbKeyNumpad1
KEY_NUMPAD_2 | vbKeyNumpad2
KEY_NUMPAD_3 | vbKeyNumpad3
KEY_NUMPAD_4 | vbKeyNumpad4
KEY_NUMPAD_5 | vbKeyNumpad5
KEY_NUMPAD_6 | vbKeyNumpad6
KEY_NUMPAD_7 | vbKeyNumpad7
KEY_NUMPAD_8 | vbKeyNumpad8
KEY_NUMPAD_9 | vbKeyNumpad9
KEY_NUMPAD_DECIMAL | vbKeyDecimal
KEY_NUMPAD_DIVIDE | vbKeyDivide
KEY_NUMPAD_MULTIPLY | vbKeyMultiply
KEY_NUMPAD_MINUS | vbKeySubtract
KEY_NUMPAD_PLUS | vbKeyAdd
KEY_NUMPAD_ENTER | vbKeySeparator
KEY_UP | vbKeyUp
KEY_DOWN | vbKeyDown
KEY_RIGHT | vbKeyRight
KEY_LEFT | vbKeyLeft
KEY_INSERT | vbKeyInsert
KEY_HOME | vbKeyHome
KEY_END | vbKeyEnd
KEY_PAGEUP | vbKeyPageUp
KEY_PAGEDOWN | vbKeyPageDown
KEY_BACKSPACE | vbKeyBack
KEY_BACKQUOTE | &HC0
KEY_COMMA | &H2C
KEY_TAB | vbKeyTab
KEY_CLEAR | vbKeyClear
KEY_RETURN | vbKeyReturn
KEY_PAUSE | vbKeyPause
KEY_PERIOD | &HBE
KEY_SLASH | &HBF
KEY_ESCAPE | vbKeyEscape
KEY_SPACE | vbKeySpace
KEY_DELETE | vbKeyDelete
KEY_NUMLOCK | vbKeyNumlock
KEY_CAPSLOCK | vbKeyCapital
KEY_SHIFT | vbKeyShift
KEY_CTRL | vbKeyControl
KEY_ALT | &H12
KEY_HELP | vbKeyHelp
KEY_PRINT | vbKeyPrint
KEY_MENU | vbKeyMenu


Matrix4
Send comments on this topic.

UDT Members

Member | Type
X1 | Single
X2 | Single
X3 | Single
X4 | Single
Y1 | Single
Y2 | Single
Y3 | Single
Y4 | Single
Z1 | Single
Z2 | Single
Z3 | Single
Z4 | Single
W1 | Single
W2 | Single
W3 | Single
W4 | Single


MD3_Death_Animations Enumeration

Members

Member | Value
BOTH_DEATH1 | 0
BOTH_DEAD1 | 1
BOTH_DEATH2 | 2
BOTH_DEAD2 | 3
BOTH_DEATH3 | 4
BOTH_DEAD3 | 5


MD3_Legs_Animations Enumeration

Members

Member | Value
LEGS_WALKCR | 13
LEGS_WALK | 14
LEGS_RUN | 15
LEGS_BACK | 16
LEGS_SWIM | 17
LEGS_JUMP | 18
LEGS_LAND | 19
LEGS_JUMPB | 20
LEGS_LANDB | 21
LEGS_IDLE | 22
LEGS_IDLECR | 23
LEGS_TURN | 24


MD3_Models Enumeration

Members

Member | Value
MD3_LOWER | 0
MD3_UPPER | 1
MD3_HEAD | 2
MD3_WEAPON | 3


MD3_Torso_Animations Enumeration

Members

Member | Value
TORSO_GESTURE | 6
TORSO_ATTACK | 7
TORSO_ATTACK2 | 8
TORSO_DROP | 9
TORSO_RAISE | 10
TORSO_STAND | 11
TORSO_STAND2 | 12


Plane_Type
Send comments on this topic.

UDT Members

Member | Type
Distance | Single
Normal | Vertex3

See Also

Vertex3


Shader_Function
Send comments on this topic.

UDT Members

Member | Type
Frequency | Single
Phase | Single
Function | Long
Index | Long
Test | Long
Type | Long
Transform | Matrix4
Position | Vertex3
Scale | Vertex2
Speed | Vertex2

See Also

Matrix4, Vertex3, Vertex2, Vertex2


Shader_Layer
Send comments on this topic.

UDT Members

Member | Type
Alpha | Single
Frame | Single
Flags | Long
Frequency | Long
Function | Long
Write | Long
Textures() | Long
Values() | Long
Mods() | Shader_Function
RGB | Shader_Function

See Also

Shader_Function


Shader_Type
Send comments on this topic.

UDT Members

Member | Type
Loaded | Boolean
Name | String
Mode | Long
Flags | Long
Program | Long
Surface | Long
Deform | Shader_Function
Layers() | Shader_Layer

See Also

Shader_Function, Shader_Layer


Vertex2 UDT

Vertex2
Send comments on this topic.

UDT Members

Member | Type
X | Single
Y | Single


Vertex2Long UDT

Vertex2Long
Send comments on this topic.

UDT Members

Member | Type
X | Long
Y | Long


Vertex3
Send comments on this topic.

UDT Members

Member | Type
X | Single
Y | Single
Z | Single


Vertex4 UDT

GameBasic 3D Engine 1.0 For Visual Basic
Vertex4 UDT
See Also Members Send comments on this topic.

UDT Members

Member | Type | Description
X | Single |
Y | Single |
Z | Single |
W | Single |

See Also

Math Standard Module


Vertex4Long
Send comments on this topic.

UDT Members

Member | Type
X | Long
Y | Long
Z | Long
W | Long


Volume_Box
Send comments on this topic.

UDT Members

Member | Type
Min | Vertex3
Max | Vertex3

See Also

Vertex3


Volume_Type
Send comments on this topic.

UDT Members

Member | Type
Visible | Boolean
Relative | Boolean
Position | Vertex3
Rotation | Vertex3
Matrix | Matrix4
Box | Volume_Box

See Also

Vertex3, Matrix4, Volume_Box